AWS Outage

Incident Report for Student First Technologies

Resolved

Requests have processed without incident since the last update.
Posted Oct 20, 2025 - 20:42 UTC

Monitoring

Throughput levels on the Theodore platform have returned to normal levels and our upstream partners are reporting resolution on their side. Our team continues to monitor performance for any issues.
Posted Oct 20, 2025 - 18:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 17:25 UTC

Update

SFT is continuing to work with upstream service providers on a full service restoration and has confirmed that no data loss has occurred. The Theodore platform is available to some users at this time, pending DNS propagation
Posted Oct 20, 2025 - 17:24 UTC

Identified

An upstream provider (AWS) is experience a global outage in the us-east-1 region affecting the Theodore platform. Our team is investigating.
Posted Oct 20, 2025 - 14:35 UTC
This incident affected: Theodore.